Which packages should be installed to have sound output working on minimal Ubuntu 20.04 LTS?

I have just installed Ubuntu 20.04 LTS from netboot mini.iso into the fresh VirtualBox 6.1 VM using default settings:

  • Host Audio Driver: PulseAudio
  • Audio Controller: ICH AC97

To install sound related applications I ran the following command on guest via SSH:

sudo apt install pulseaudio alsa-base alsa-utils vlc --no-install-recommends

As starting point I would like to hear sounds from the following commands:

aplay /usr/share/sounds/alsa/Noise.wav
cvlc /usr/share/sounds/alsa/Noise.wav

but currently they do not make sound.

Some extra information:

$ lspci -k | grep -i audio -A2
00:05.0 Multimedia audio controller: Intel Corporation 82801AA AC'97 Audio Controller (rev 01)
    Subsystem: Dell 82801AA AC'97 Audio Controller
    Kernel driver in use: snd_intel8x0
    Kernel modules: snd_intel8x0
$ lsmod | grep snd
snd_intel8x0           45056  0
snd_ac97_codec        131072  1 snd_intel8x0
ac97_bus               16384  1 snd_ac97_codec
snd_pcm               106496  2 snd_intel8x0,snd_ac97_codec
snd_seq_midi           20480  0
snd_seq_midi_event     16384  1 snd_seq_midi
snd_rawmidi            36864  1 snd_seq_midi
snd_seq                69632  2 snd_seq_midi,snd_seq_midi_event
snd_seq_device         16384  3 snd_seq,snd_seq_midi,snd_rawmidi
snd_timer              36864  2 snd_seq,snd_pcm
snd                    90112  7 snd_seq,snd_seq_device,snd_intel8x0,snd_timer,snd_ac97_codec,snd_pcm,snd_rawmidi
soundcore              16384  1 snd
$ aplay -l
aplay: device_list:276: no soundcards found...
$ aplay -L
default
    Playback/recording through the PulseAudio sound server
null
    Discard all samples (playback) or generate zero samples (capture)
samplerate
    Rate Converter Plugin Using Samplerate Library
speexrate
    Rate Converter Plugin Using Speex Resampler
jack
    JACK Audio Connection Kit
oss
    Open Sound System
pulse
    PulseAudio Sound Server
upmix
    Plugin for channel upmix (4,6,8)
vdownmix
    Plugin for channel downmix (stereo) with a simple spacialization
$ alsamixer 
cannot open mixer: No such file or directory
$ aplay /usr/share/sounds/alsa/Noise.wav 
Playing WAVE '/usr/share/sounds/alsa/Noise.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono

Answers 1

  • Surprisingly the real solution is to add my user to the audio group by executing

    sudo usermod -a -G audio $USER
    

    This is not needed for local users, but it is needed for SSH-user.


Related Questions